1.
Pengertian Protokol
Sebelum membahas lebih jauh
tentang pengertian dari masing-masing layer dalam protokol, alangkah baiknya
kita mengetahui terlebih dahulu apa itu protokol dalam sebuah Jaringan Komputer
? Protokol adalah sebuah aturan atau standar yang mengatur
atau mengijinkan terjadinya hubungan, komunikasi, dan perpindahan data antara
dua atau lebih titik komputer. Protokol dapat diterapkan pada perangkat keras,
perangkat lunak atau kombinasi dari keduanya. Pada tingkatan yang terendah,
protokol mendefinisikan koneksi perangkat keras. Prinsip dalam membuat protokol
ada tiga hal yang harus dipertimbangkan, yaitu efektivitas, kehandalan, dan
Kemampuan dalam kondisi gagal di network. Protokol distandarisasi oleh beberapa
organisasi yaitu IETF, ETSI, ITU, dan ANSI. Tugas yang biasanya dilakukan oleh
sebuah protokol dalam sebuah jaringan diantaranya adalah :
·
Melakukan
deteksi adanya koneksi fisik atau ada tidaknya komputer / mesin lainnya.
·
Melakukan
metode “jabat-tangan” (handshaking).
·
Negosiasi
berbagai macam karakteristik hubungan.
·
Bagaimana
mengawali dan mengakhiri suatu pesan.
·
Bagaimana
format pesan yang digunakan.
·
Yang
harus dilakukan saat terjadi kerusakan pesan atau pesan yang tidak sempurna.
·
Mendeteksi
rugi-rugi pada hubungan jaringan dan langkah-langkah yang dilakukan
selanjutnya.
2.
Lapisan Pada Protocol TCP/IP
TCP/IP (Transmission Control
Protokol / Internet Protokol ) adalah standar komunikasi data yang
digunakan oleh komunitas internet dalam proses tukar-menukar data dari satu
komputer ke komputer lain di dalam jaringan Internet. Protokol TCP/IP
dikembangkan pada akhir dekade 1970-an hingga awal 1980-an sebagai sebuah
protokol standar untuk menghubungkan komputer-komputer dan jaringan untuk
membentuk sebuah jaringan yang luas (WAN). TCP/IP merupakan sebuah standar
jaringan terbuka yang bersifat independen terhadap mekanisme transport jaringan
fisik yang digunakan, sehingga dapat digunakan di mana saja.
Definisi Masing-masing
Layer pada model TCP/IP

GAMBAR: Susunan model OSI
dan TCP/IP empat lapis
TCP/IP dikembangkan sebelum
model OSI ada. Namun demikian lapisan-lapisan pada TCP/IP tidaklah cocok
seluruhnya dengan lapisan-lapisan OSI. Protokol TCP/IP hanya dibuat atas lima
lapisan saja: physical, data link, network, transport dan application. Hanya lapisan
aplikasi pada TCP/IP mencakupi tiga lapisan OSI teratas, sebagaimana dapat
dilihat pada Gambar berikut. Khusus layer keempat, Protokol TCP/IP
mendefinisikan 2 buah protokol yakni Transmission Control Protocol (TCP) dan
User Datagram Protocol Protocol (UDP). Sementara itu pada lapisan ketiga,
TCP/IP mendefiniskan sebagai Internetworking Protocol (IP), namun ada beberapa
protokol lain yang mendukung pergerakan data pada lapisan ini.
GAMBAR: Susunan model OSI
dan TCP/IP lima lapis

1. Physical
Layer. Pada
lapisan ini TCP/IP tidak mendefinisikan protokol yang spesifik. Artinya TCP/IP
mendukung semua standar dan proprietary protokol lain. Pada lapisan ini
ditentukan karakteristik media transmisi, rata-rata pensinyalan, serta skema
pengkodean sinyal dan sarana sistem pengiriman data ke device yang terhubung ke
network
2.
Data Link Layer. Berkaitan dengan logical-interface diantara
satu ujung sistem dan jaringan dan melakukan fragmentasi atau defragmentasi
datagram. Ada juga beberapa pendapat yang menggabungkan lapisan ini dengan
lapisan fisik sehingga kedua lapisan ini dianggap sebagai satu lapisan,
sehingga TCP/IP dianggap hanya terdiri dari empat lapis. Perhatikan
perbandingannya pada kedua gambar di atas.
3.
Network Layer Internet Protocol (IP). Berkaitan dengan
routing data dari sumber ke tujuan. Pelayanan pengiriman paket elementer.
Definisikan datagram (jika alamat tujuan tidak dalam jaringan lokal, diberi
gateway = device yang menswitch paket antara jaringan fisik yang beda;
memutuskan gateway yang digunakan). Pada lapisan ini TCP/IP mendukung IP dan
didukung oleh protokol lain yaitu RARP, ICMP, ARP dan IGMP.
1.
Internetworking Protocol (IP) Adalah mekanisme
transmisi yang digunakan oleh TCP/IP. IP disebut juga unreliabledan connectionless datagram
protocol-a besteffort delivery service. IP mentransportasikan data dalam
paket-paket yang disebut datagram.
2.
Address Resolution Protocol (ARP) ARP digunakan untuk
menyesuaikan alamat IP dengan alamatfisik (Physical address).
3.
Reverse Address Resolution Protocol (RARP) RARP membolehkan host
menemukan alamat IP nya jika dia sudah tahu alamat fiskinya. Ini berlaku pada
saat host baru terkoneksi ke jaringan.
4.
Internet Control Message Protocol (ICMP) ICMP adalah suatu mekanisme
yang digunakan oleh sejumlah host dan gateway untuk mengirim notifikasi
datagram yang mengalami masalah kepada host pengirim.Internet
5.
Group Message Protocol (IGMP) IGMP digunakan untuk
memfasilitasi transmisi message yang simultan kepasa kelompok/group penerima.
4.
Transport Layer. Pada lapisan ini terbagi menjadi dua, UDP dan
TCP
1.
User Datagram Protocol (UDP) UDP adalah protokol
process-to-process yang menambahakan hanya alamat port, check-sum error
control, dan panjang informasi data dari lapisan di atasnya. (Connectionless)
2.
Transmission Control Protocol (TCP) TCP menyediakan layanan
penuh lapisan transpor untuk aplikasi. TCP juga dikatakan protokol transport
untuk stream yang reliabel. Dalam konteks ini artinya TCP bermakna
connectionoriented, dengan kata lain: koneksi end-to-end harus dibangun dulu di
kedua ujung terminal sebelum kedua ujung terminal mengirimkan data. (Connection
Oriented)
5.
Application Layer. Layer dalam TCP/IP adalah
kombinasi lapisan-lapisan session, presentation dan application pada
OSI yang menyediakan komunikasi diantara proses atau aplikasi-aplikasi pada
host yang berbeda: telnet, ftp, http,dll.

GAMBAR: Protocol Data Unit
(PDU) pada arsitektur TCP/IP
Untuk mengontrol operasi
pertukaran data, informasi kontrol serta data user harus ditransmisikan,
sebagaimana digambarkan pada gambar di bawah. Dapat dikatakan bahwa proses
pengiriman menggerakkan satu blok data dan meneruskannya ke TCP. TCP memecah
blok data ini menjadi bagian-bagian kecil agar mudah disusun. Untuk setiap
bagian-bagian kecil ini, TCP menyisipkan informasi kontrol yang disebut sebagai
TCP header, yang akhirnya membentuk segmen TCP. Informasi kontrol dipergunakan
oleh pasangan (peer) entiti protokol TCP pada host lainnya. Contoh item-item
yang termasuk dalam header ini adalah sebagai berikut:
·
Destination port: saat entiti penerima TCP menerima
segmen TCP, harus diketahui kepada siapa data tersebut dikirimkan.
·
Sequence number: TCP memberikan nomor yang dikirim
secara bertahap ke port tujuan, sehingga jika destination menerima tidak sesuai
dengan urutannya, maka entiti destination akan meminta untuk dikirim kembali.
·
Checksum: pada pengiriman segmen TCP diikutkan
pula suatu kode yang yang disebut dengan segment remainder. Remainder TCP
yang diterima akan dikalkulasi dan dibandingkan hasilnya dengan kode yang
datang. Jika terjadi ketidasesuaian, berarti telah terjadi kesalahan transmisi.
Sebagai tambahan Application merupakan
Layer paling atas pada model TCP/IP, yang bertanggung jawab untuk menyediakan
akses kepada aplikasi terhadap layanan jaringan TCP/IP. Protokol ini mencakup
protokol Dynamic Host Configuration Protocol (DHCP), Domain Name System (DNS),
Hypertext Transfer Protocol (HTTP), File Transfer Protocol (FTP), Telnet,
Simple Mail Transfer Protocol (SMTP), Simple Network Management Protocol
(SNMP), dan masih banyak protokol lainnya. Dalam beberapa implementasi Stack
Protocol, seperti halnya Microsoft TCP/IP, protokol-protokol lapisan aplikasi
berinteraksi dengan menggunakan antarmuka Windows Sockets (Winsock) atau
NetBios over TCP/IP (NetBT).
3.
Lapisan Model Osi Layer
Pengertian model OSI (Open
System Interconnection) adalah suatu model konseptual yang terdiri atas tujuh
layer, yang masing-masing layer tersebut mempunyai fungsi yang berbeda. OSI
dikembangkan oleh badan Internasional yaitu ISO (International Organization for
Standardization) pada tahun 1977. Model ini juga dikenal dengan model tujuh
lapis OSI (OSI seven layer model). Berikut dibawah ini merupakan gambar
dari model OSI 7 LayerBerikut deskripsi Model referensi OSI:
·
Sebuah
Model Layer
·
Setiap
layer melakukan sekumpulan fungsi tertentu untuk mensukseskan komunikasi data
·
Setiap
layer bergantung pada layer yang ada di bawahnya untuk melakukan fungsinya
·
Setiap
layer akan mendukung operasi lapisan yang berada di atasnya
·
Implementasi
pada setiap lapis seharusnya tidak bergantung pada lapisan lainnya
Definisi masing-masing
Layer pada model OSI
1.Physical adalah Layer
paling bawah dalam model OSI. Berfungsi untuk mendefinisikan media transmisi
jaringan, metode pensinyalan, sinkronisasi bit, arsitektur jaringan (seperti
halnya Ethernet atau Token Ring), topologi jaringan dan pengabelan. Selain itu,
level ini juga mendefinisikan bagaimana Network Interface Card (NIC) dapat
berinteraksi dengan media kabel atau radio.
2.Data Link Befungsi untuk
menentukan bagaimana bit-bit data dikelompokkan menjadi format yang disebut
sebagai frame. Selain itu, pada level ini terjadi koreksi
kesalahan, flow control, pengalamatan perangkat keras seperti
halnya Media Access Control Address (MAC Address), dan menetukan bagaimana
perangkat-perangkat jaringan seperti hub, bridge, repeater, dan switch layer2
beroperasi. Spesifikasi IEEE 802, membagi level ini menjadi
dua level anak, yaitu lapisan Logical Link Control (LLC) dan lapisan Media
Access Control (MAC).
3. Network Berfungsi untuk mendefinisikan
alamat-alamat IP, membuat header untuk paket-paket, dan
kemudian melakukan routing melalui internetworking dengan
menggunakan router dan switch layer3.
4. Transport Berfungsi untuk memecah
data ke dalam paket-paket data serta memberikan nomor urut ke paket-paket
tersebut sehingga dapat disusun kembali pada sisi tujuan setelah diterima.
Selain itu, pada level ini juga membuat sebuah tanda bahwa paket diterima
dengan sukses (acknowledgement), dan mentransmisikan ulang terhadap paket-paket
yang hilang di tengah jalan.
5. Session Berfungsi untuk mendefinisikan
bagaimana koneksi dapat dibuat, dipelihara, atau dihancurkan. Selain itu, di
level ini juga dilakukan resolusi nama.
6. Presentation berfungsi untuk
mentranslasikan data yang hendak ditransmisikan oleh aplikasi ke dalam format
yang dapat ditransmisikan melalui jaringan. Protokol yang berada dalam level
ini adalah perangkat lunak redirektor (redirector software), seperti
layanan Workstation (dalam windows NT) dan juga Network shell
(semacam Virtual network komputing (VNC) atau Remote Dekstop Protokol (RDP).
7. Application adalah Layer paling tinggi
dari model OSI, seluruh layer dibawahnya bekerja untuk layer ini, tugas
dari application layer adalah Berfungsi sebagai antarmuka dengan aplikasi
dengan fungsionalitas jaringan, mengatur bagaimana aplikasi dapat mengakses
jaringan, dan kemudian membuat pesan-pesan kesalahan. Protokol yang berada
dalam lapisan ini adalah HTTP, FTP, SMTP, NFS.
Cara Kerja Model OSI
Cara Kerja :
Pembentukan paket dimulai dari layer teratas model OSI. Aplication layer
megirimkan data ke presentation layer, di presentation layer data ditambahkan
header dan atau tailer kemudian dikirim ke layer dibawahnya, pada layer
dibawahnya pun demikian, data ditambahkan header dan atau tailer kemudian
dikirimkan ke layer dibawahnya lagi, terus demikian sampai ke physical layer.
Di physical layer data dikirimkan melalui media transmisi ke host tujuan. Di
host tujuan paket data mengalir dengan arah sebaliknya, dari layer paling bawah
kelayer paling atas. Protokol pada physical layer di host tujuan mengambil
paket data dari media transmisi kemudian mengirimkannya ke data link layer,
data link layer memeriksa data-link layer header yang ditambahkan host pengirim
pada paket, jika host bukan yang dituju oleh paket tersebut maka paket itu akan
di buang, tetapi jika host adalah yang dituju oleh paket tersebut maka paket
akan dikirimkan ke network layer, proses ini terus berlanjut sampai ke
application layer di host tujuan. Proses pengiriman paket dari layer ke layer
ini disebut dengan “peer-layer communication
4.Pengertian
Masing-Masing Protocol ialah sebagai berikut:
1.HTTP (Hypertext Transfer
Protocol) suatu protokol yang digunakan oleh WWW (World Wide Web). HTTP
mendefinisikan bagaimana suatu pesan bisa diformat dan dikirimkan dari server
ke client. HTTP juga mengatur aksi-aksi apa saja yang harus dilakukan oleh web server
dan juga web browser sebagai respon atas perintah-perintah yang ada pada
protokol HTTP ini.Hingga kini, ada dua versi mayor dari protokol HTTP, yakni
HTTP/1.0 yang menggunakan koneksi terpisah untuk setiap dokumen, dan HTTP/1.1
yang dapat menggunakan koneksi yang sama untuk melakukan transaksi. Dengan
demikian, HTTP/1.1 bisa lebih cepat karena memang tidak usah membuang waktu
untuk pembuatan koneksi berulang-ulang.
2.HTTPS (Securre HTTP)
merupakan bentuk protokol yang aman karena segala perintah dan data yang lewat
protokol ini akan diacak dengan berbagai format sehingga sulit untuk dibajak
isinya maupun dilihat perintah-perintah yang dieksekusi.
3.FTP (File Transfer
Protocol) adalah sebuah protokol Internet yang berjalan di dalam lapisan
aplikasi yang merupakan standar untuk pentransferan berkas (file) komputer
antar mesin-mesin dalam sebuah internetwork. FTP merupakan salah satu protokol
Internet yang paling awal dikembangkan, dan masih digunakan hingga saat ini
untuk melakukan pengunduhan (download) dan penggugahan (upload) berkas-berkas
komputer antara klien FTP dan server FTP. Pada umumnya browser-browser versi
terbaru sudah mendukung FTP.
4.SMTP(Simple Mail Transfer
Protocol) adalah suatu protokol yang digunakan untuk mengirimkan pesan e-mail
antar server, yang bisa dianalogikan sebagai kantor pos.
5.POP atau Post Office
Protocol, sesuai dengan namanya merupakan protokol yang digunakan untuk
pengelolaan mail. POP yang sekarang lebih umum dikenal dengan POP3 (POP –
Version 3), dimaksudkan untuk mengizinkan client untuk mengakses secara dinamis
mail yang masih ada di POP3 server. POP3 menawarkan pada user untuk
meninggalkan mail-nya di POP3 server, dan mengambil mail-nya tersebut dari
sejumlah sistem sebarang. Untuk mengambil mail dengan menggunakan POP3 dari
suatu client, banyak pilihan yang dapat digunakan seperti Sun Microsystem
Inc.’s Mailtool, QualComm Inc.’s Eudora, Netscape Comm. Corp.’s Netscape Mail
dan Microsoft Corp.’s Outlook Express.
POP3
tidak dimaksudkan untuk menyediakan operasi manipulasi mail yang ada di server
secara luas. Pada POP3, mail diambil dari server dan kemudian dihapus (bisa
juga tidak dihapus). Segala sesuatu tentang protokol POP3 ini dibahas dalam RFC
(Request For Comment) 1725. Protokol yang lebih tinggi dan lebih kompleks,
yaitu IMAP4, dibahas dalam RFC 1730.
Mode POP3
Ada dua jenis mode pada
POP3 yaitu mode offline dan mode inline. Pada mode offline, POP3 mengambil dan
kemudian menghapus mail yang tersimpan dari server. POP3 bekerja dengan baik
pada mode ini, karena terutama memang didisain untuk berlaku sebagai sebuah
sistem mail yang memiliki sifat “store-and-forward”. Server, pada mode offline,
berlaku seperti sebuah tempat penampungan yang menyimpan mail sampai user
memintanya.
6.IMAP (Internet Message
Access Protocol) adalah protokol standar untuk mengakses/mengambil e-mail dari
server. IMAP memungkinkan pengguna memilih pesan e-mail yang akan ia ambil,
membuat folder di server, mencari pesan e-mail tertentu, bahkan menghapus pesan
e-mail yang ada.
5.Perbedaan
antara UDP dan TCP
User Datagram Protocol
(UDP) UDP
adalah protokol process-to-process yang menambahakan hanya alamat port,
check-sum error control, dan panjang informasi data dari lapisan di atasnya. (Connectionless)
UDP memiliki
karakteristik-karakteristik berikut:
·
Connectionless (tanpa koneksi): Pesan-pesan UDP akan
dikirimkan tanpa harus dilakukan proses negosiasi koneksi antara dua host yang
hendak berukar informasi.
·
Unreliable (tidak andal): Pesan-pesan UDP akan
dikirimkan sebagai datagram tanpa adanya nomor urut atau pesan .Protokol
lapisan aplikasi yang berjalan di atas UDP harus melakukan pemulihan terhadap
pesan-pesan yang hilang selama transmisi. Umumnya, protokol lapisan aplikasi
yang berjalan di atas UDP mengimplementasikan layanan keandalan mereka
masing-masing, atau mengirim pesan secara periodik atau dengan menggunakan
waktu yang telah didefinisikan.
·
UDP
menyediakan mekanisme untuk mengirim pesan-pesan ke sebuah protokol lapisan
aplikasi atau proses tertentu di dalam sebuah host dalam jaringan yang
menggunakan TCP/IP. Header UDP berisi field Source
Process Identification dan Destination Process Identification.
·
UDP
menyediakan penghitungan checksum berukuran 16-bit terhadap keseluruhan pesan
UDP.
UDP tidak menyediakan
layanan-layanan antar-host berikut:
·
UDP
tidak menyediakan mekanisme penyanggaan (buffering) dari data yang masuk
ataupun data yang keluar. Tugas buffering merupakan tugas yang harus
diimplementasikan oleh protokol lapisan aplikasi yang berjalan di atas UDP.
·
UDP
tidak menyediakan mekanisme segmentasi data yang besar ke dalam segmen-segmen
data, seperti yang terjadi dalam protokol TCP. Karena itulah, protokol lapisan
aplikasi yang berjalan di atas UDP harus mengirimkan data yang berukuran kecil
(tidak lebih besar dari nilai Maximum Transfer Unit/MTU)
yang dimiliki oleh sebuah antarmuka di mana data tersebut dikirim. Karena, jika
ukuran paket data yang dikirim lebih besar dibandingkan nilai MTU, paket data
yang dikirimkan bisa saja terpecah menjadi beberapa fragmen yang akhirnya tidak
jadi terkirim dengan benar.
UDP sering digunakan dalam
beberapa tugas berikut:
·
Protokol
yang "ringan" (lightweight): Untuk menghemat sumber daya memori dan
prosesor, beberapa protokol lapisan aplikasi membutuhkan penggunaan protokol
yang ringan yang dapat melakukan fungsi-fungsi spesifik dengan saling bertukar
pesan. Contoh dari protokol yang ringan adalah fungsi query nama dalam protokol
lapisan aplikasi.Domain Name System
·
Protokol
lapisan aplikasi yang mengimplementasikan layanan keandalan: Jika protokol
lapisan aplikasi menyediakan layanan transfer data yang andal, maka kebutuhan
terhadap keandalan yang ditawarkan oleh TCP pun menjadi tidak ada. Contoh dari
protokol seperti ini adalah Trivial File Transfer Protocol (TFTP) dan Network
File System (NFS)
·
Protokol
yang tidak membutuhkan keandalan. Contoh protokol ini adalah protokol Routing Information
Protocol (RIP).
·
Transmisi
broadcast: Karena UDP merupakan protokol yang tidak perlu membuat koneksi
terlebih dahulu dengan sebuah host tertentu, maka transmisi broadcast pun
dimungkinkan. Sebuah protokol lapisan aplikasi dapat mengirimkan paket data ke
beberapa tujuan dengan menggunakan alamat multicast atau broadcast. Hal ini
kontras dengan protokol TCP yang hanya dapat mengirimkan transmisi one-to-one.
Contoh: query nama dalam protokol NetBIOS Name Service.
UDP, berbeda dengan TCP
yang memiliki satuan paket data yang disebut dengan segmen,
melakukan pengepakan terhadap data ke dalam pesan-pesan UDP (UDP Messages).
Sebuah pesan UDP berisi header UDP dan akan dikirimkan ke
protokol lapisan selanjutnya (lapisan internetwork) setelah mengepaknya menjadi
datagram IP. Enkapsulasi terhadap pesan-pesan UDP oleh protokol IP
dilakukan dengan menambahkan header IP dengan protokol IP nomor 17 (0x11).
Pesan UDP dapat memiliki besar maksimum 65507 byte: 65535 (216)-20
(ukuran terkecil dari header IP)-8 (ukuran dari header UDP) byte. Datagram
IP yang dihasilkan dari proses enkapsulasi tersebut, akan
dienkapsulasi kembali dengan menggunakan header dan trailer protokol
lapisan Network Interface yang digunakan oleh host tersebut.
Dalam header IP
dari sebuah pesan UDP, field Source IP Address akan diset ke antarmuka host
yang mengirimkan pesan UDP yang bersangkutan; sementara field Destination IP
Address akan diset ke alamat IP multicast dari sebuah host tertentu, alamat IP
broadcast, atau alamat IP multicast.
Transmission Control
Protocol (TCP) TCP
menyediakan layanan penuh lapisan transpor untuk aplikasi. TCP juga dikatakan
protokol transport untuk stream yang reliabel. Dalam konteks ini artinya TCP
bermakna connectionoriented, dengan kata lain: koneksi end-to-end harus
dibangun dulu di kedua ujung terminal sebelum kedua ujung terminal mengirimkan
data. (Connection Oriented)
Protokol TCP/IP selalu
berevolusi seiring dengan waktu, mengingat semakin banyaknya kebutuhan terhadap
jaringan komputer dan Internet. Pengembangan ini dilakukan oleh beberapa badan,
seperti halnya Internet Society (ISOC), Internet Architecture Board (IAB), dan Internet Engineering Task Force (IETF).
Macam-macam protokol yang berjalan di atas TCP/IP, skema pengalamatan, dan
konsep TCP/IP didefinisikan dalam dokumen yang disebut sebagai Request for Comments (RFC)
yang dikeluarkan oleh IETF.
Protokol TCP/IP menggunakan
dua buah skema pengalamatan yang dapat digunakan untuk mengidentifikasikan
sebuah komputer dalam sebuah jaringan atau jaringan dalam sebuah internetwork,
yakni sebagai berikut:
·
Pengalamatan
IP: yang berupa alamat logis yang terdiri atas 32-bit (empat oktet berukuran
8-bit) yang umumnya ditulis dalam format www.xxx.yyy.zzz. Dengan menggunakan subnet mask yang
diasosiasikan dengannya, sebuah alamat IP pun dapat dibagi menjadi dua bagian,
yakni Network Identifier (NetID) yang dapat
mengidentifikasikan jaringan lokal dalam sebuah internetwork dan Host
identifier (HostID) yang dapat mengidentifikasikan host dalam jaringan
tersebut. Sebagai contoh, alamat 205.116.008.044 dapat dibagi dengan menggunakan subnet
mask255.255.255.000 ke dalam Network
ID 205.116.008.000 dan Host ID 44.
Alamat IP merupakan kewajiban yang harus ditetapkan untuk sebuah host,
yang dapat dilakukan secara manual (statis) atau menggunakan Dynamic
Host Configuration Protocol (DHCP) (dinamis).
·
Fully
qualified domain name (FQDN): Alamat ini merupakan alamat yang
direpresentasikan dalam nama alfanumerik yang diekspresikan dalam bentuk <nama_host>.<nama_domain>,
di mana <nama_domain> mengindentifikasikan jaringan di mana sebuah
komputer berada, dan <nama_host> mengidentifikasikan sebuah komputer
dalam jaringan. Pengalamatan FQDN digunakan oleh skema penamaan domain Domain
Name System (DNS). Sebagai contoh, alamat FQDN id.wikipedia.org merepresentasikan
sebuah host dengan nama "id" yang terdapat di dalam domain
jaringan "wikipedia.org".Nama Domain wikipedia.org merupakan second-level domain yang
terdaftar di dalam top-level domain .org, yang terdaftar dalam root DNs, yang
memiliki nama "." (titik). Penggunaan FQDN lebih bersahabat
dan lebih mudah diingat ketimbang dengan menggunakan alamat IP. Akan tetapi,
dalam TCP/IP, agar komunikasi dapat berjalan, FQDN harus diterjemahkan terlebih
dahulu (proses penerjemahan ini disebut sebagai resolusi nama) ke
dalam alamat IP dengan menggunakan server yang menjalankan
DNS, yang disebut dengan Name Server atau dengan menggunakan
berkas hosts (/etc/hosts atau %systemroot%\system32\drivers\etc\hosts) yang disimpan di dalam
mesin yang bersangkutan.
Berikut ini adalah layanan
tradisional yang dapat berjalan di atas protokol TCP/IP:
·
Pengiriman berkas (file transfer). File Transfer
Protocol(FTP) memungkinkan pengguna komputer yang satu untuk dapat mengirim
ataupun menerima berkas ke sebuah host di dalam jaringan. Metode otentikasi
yang digunakannya adalah penggunaan nama pengguna (user name) dan [[password]],
meskipun banyak juga FTP yang dapat diakses secara anonim (anonymous),
alias tidak berpassword. (Keterangan lebih lanjut mengenai FTP dapat
dilihat pada RFC 959.)
·
Remote login. Network terminal Protocol (telnet)
memungkinkan pengguna komputer dapat melakukan log in ke dalam
suatu komputer di dalam suatu jaringan secara jarak jauh. Jadi hal ini berarti
bahwa pengguna menggunakan komputernya sebagai perpanjangan tangan dari
komputer jaringan tersebut. (Keterangan lebih lanjut mengenai Telnet dapat
dilihat pada RFC 854 dan RFC 855.)
·
Computer mail. Digunakan untuk menerapkan sistem surat
elektronik. (Keterangan lebih lanjut mengenai e-mail dapat dilihat pada RFC 821
dan RFC 822.)
·
Network File System (NFS). Pelayanan akses
berkas-berkas yang dapat diakses dari jarak jauh yang memungkinkan klien-klien
untuk mengakses berkas pada komputer jaringan, seolah-olah berkas tersebut
disimpan secara lokal. (Keterangan lebih lanjut mengenai NFS dapat dilihat RFC
1001 dan RFC 1002.)
·
Remote execution. Memungkinkan pengguna komputer untuk
menjalankan suatu program tertentu di dalam komputer yang
berbeda. Biasanya berguna jika pengguna menggunakan komputer yang terbatas,
sedangkan ia memerlukan sumber yg banyak dalam suatu sistem komputer.
Ada beberapa jenis remote execution, ada yang berupa perintah-perintah dasar saja, yaitu yang dapat dijalankan dalam system komputer yang sama dan ada pula yg menggunakan sistem Remote Procedure Call (RPC), yang memungkinkan program untuk memanggil subrutin yang akan dijalankan di sistem komputer yg berbeda. (sebagai contoh dalam Berkeley UNIX ada perintah rsh dan rexec.)
Ada beberapa jenis remote execution, ada yang berupa perintah-perintah dasar saja, yaitu yang dapat dijalankan dalam system komputer yang sama dan ada pula yg menggunakan sistem Remote Procedure Call (RPC), yang memungkinkan program untuk memanggil subrutin yang akan dijalankan di sistem komputer yg berbeda. (sebagai contoh dalam Berkeley UNIX ada perintah rsh dan rexec.)
·
Name server yang berguna sebagai penyimpanan basis
data nama host yang digunakan pada Internet (Keterangan lebih lanjut dapat
dilihat pada RFC 822 dan RFC 823 yang menjelaskan mengenai penggunaan protokol name
serveryang bertujuan untuk menentukan nama host di
Internet.)
Dikarenakan TCP/IP adalah
serangkaian protokol di mana setiap protokol melakukan sebagian dari
keseluruhan tugas komunikasi jaringan, maka tentulah implementasinya tak lepas
dari arsitektur jaringan itu sendiri. Arsitektur rangkaian protokol TCP/IP
mendifinisikan berbagai cara agar TCP/IP dapat saling menyesuaikan.
Karena TCP/IP merupakan
salah satu lapisan protokol Model OSI, berarti bahwa hierarki TCP/IP merujuk
kepada 7 lapisan OSI tersebut. Tiga lapisan teratas biasa dikenal sebagai
"upper level protocol" sedangkan empat lapisan terbawah
dikenal sebagai "lower level protocol". Tiap lapisan berdiri
sendiri tetapi fungsi dari masing-masing lapisan bergantung dari keberhasilan
operasilayer sebelumnya. Sebuah lapisan pengirim hanya perlu
berhubungan dengan lapisan yang sama di penerima (jadi misalnya lapisan data
link penerima hanya berhubungan dengan lapisan data link pengirim)
selain dengan satu layer di atas atau di bawahnya (misalnya
lapisan network berhubungan dengan lapisan transpor di atasnya atau dengan
lapisan data link di bawahnya).
Model dengan menggunakan
lapisan ini merupakan sebuah konsep yang penting karena suatu fungsi yang rumit
yang berkaitan dengan komunikasi dapat dipecahkan menjadi sejumlah unit yang
lebih kecil. Tiap lapisan bertugas memberikan layanan tertentu pada lapisan
diatasnya dan juga melindungi lapisan diatasnya dari rincian cara pemberian
layanan tersebut. Tiap lapisan harus transparan sehingga modifikasi yang
dilakukan atasnya tidak akan menyebabkan perubahan pada lapisan yang lain.
Lapisan menjalankan perannya dalam pengalihan data dengan mengikuti peraturan
yang berlaku untuknya dan hanya berkomunikasi dengan lapisan yang setingkat.
Akibatnya sebuah layer pada satu sistem tertentu hanya akan berhubungan dengan
lapisan yang sama dari sistem yang lain. Proses ini dikenal sebagai Peer
process. Dalam keadaan sebenarnya tidak ada data yang langsung dialihkan
antar lapisan yang sama dari dua sistem yang berbeda ini. Lapisan atas akan
memberikan data dan kendali ke lapisan dibawahnya sampai lapisan yang terendah
dicapai. Antara dua lapisan yang berdekatan terdapat interface (antarmuka). Interfaceini
mendifinisikan operasi dan layanan yang diberikan olehnya ke lapisan lebih
atas. Tiap lapisan harus melaksanakan sekumpulan fungsi khusus yang dipahami
dengan sempurna. Himpunan lapisan dan protokol dikenal sebagai "arsitektur
jaringan".
6.
Pengertian ARP
Address Resolution Protocol disingkat ARP adalah
sebuah protocol dalam TCP/IP Protocol Suite yang bertanggungjawab dalam
melakukan resolusi alamat IP ke dalam alamat Media Access Control
(MAC address). ARP didefinisikan di dalam RFC 826.
Ketika sebuah aplikasi yang
mendukung teknologi Protocol Jaringan TCP/IP mencoba untuk mengakses sebuah host TCP/IP
dengan menggunakan alamat IP, maka alamat IP yang dimiliki oleh host yang
dituju harus diterjemahkan terlebih dahulu ke dalam MAC address agar frame-frame data
dapat diteruskan ke tujuan dan diletakkan di atas media transmisi (kabel,
radio, atau cahaya), setelah diproses terlebih dahulu oleh Network Interface
Card (NIC).
Hal ini dikarenakan NIC beroperasi dalam lapisan fisik dan lapisan data-link
pada tujuh lapis model referensi OSI dan
menggunakan alamat fisik daripada menggunakan alamat logis (seperti halnya
alamat IP atau nama NetBIOS) untuk
melakukan komunikasi data dalam jaringan.
Jika memang alamat yang
dituju berada di luar jaringan lokal, maka ARP akan mencoba untuk mendapatkan MAC
address dari antarmuka router lokal yang menghubungkan jaringan lokal
ke luar jaringan (di mana komputer yang dituju berada).
7.
Operator Bitwise
digunakan untuk melakukan
pemanipulasian data dalam bentuk bit (bilangan biner) seluruh operator bit
hanya dapat digunakan pada operan integer atau karakter
|
Operasi
|
keterangan
|
|
&
|
Bit
AND
|
|
^
|
Bit
XOR
|
|
|
|
Bit
OR
|
|
-
|
Bit
NOT
|
|
>>
|
Geser
kekanan
|
|
<<
|
Geser
kekiri
|